Open File - Security Warning

Last reviewed: 07/23/2009
Article ID: R11124

The information in this article applies to:

Open File - Security Warning Example

Fig. 1,  Open File - Security Warning Example

Summary

If the Local intranet zone settings are too restrictive or if the Windows Firewall does not recognize the program you are trying to run, then one of the following warning messages may be displayed when opening Tabs3 or PracticeMaster programs.

These warnings will list the name of the executable and ask if you want to run the program. This article will show you how to avoid these warnings in the future.

Cause

These warning messages may occur when the Local intranet zone settings do not allow executables to be run over the network or if the executable being opened does not have a digitally-signed certificate. These situations will cause Windows XP Service Pack 2 (and later) to not recognize the publisher and generate a warning.

Windows Security Alert Example

Fig. 2,  Windows Security Alert Example

There are two types of warnings that may appear.

Resolution

These warnings occur when the executable you are opening is being executed over your local network or does not have a digitally-signed certificate. If you are unsure about the name or nature of the executable, check with your system administrator or check our list of file names to determine if it is a Tabs3 or PracticeMaster executable.

If you receive a Windows Security Alert, similar to the image in Fig. 2, simply clicking Unblock will solve the problem. However, if you receive a warning similar to the image in Fig. 1, then changing the Local Intranet Security Settings in Internet Explorer may fix the problem. This is a two-step process:

Caution: We recommend you check with your system administrator before making any security changes.

Step 1 - Verify Site permissions for the Local Intranet zone:

The Local Intranet zone's Sites setting can cause a Local File - Security Warning. The following procedures differ slightly, depending on what version of Internet Explorer is installed:

To determine what version of Internet Explorer is installed, see KB Article R10979, "How to Check Which Version of Internet Explorer is Installed."

Using Internet Explorer 8 & 7

The addition of a check box labeled Automatically detect intranet network to the Local intranet dialog box can also lead to receiving the warning similar to Fig. 1. Having this check box selected does not ensure recognition of all intranet assets.  Use the following steps to ensure Local intranet asset identification.

To change Local Intranet zone settings in Internet Explorer 8 & 7:

  1. Open Microsoft Internet Explorer.
  2. From the Tools menu, select Internet Options.
  3. Click on the Security tab.
  4. Select the Local intranet icon and click the Sites... button, as indicated in Fig. 4.
  5. You will see the Local intranet dialog box. If the Automatically detect intranet network check box is selected, then deselect it, and ensure that the Include all network paths (UNCs) check box is selected, as shown in Fig. 4. The other settings here, Include all local (intranet) sites not listed in other zones and Include all sites that bypass the proxy server may or may not be needed, depending on your server configuration. We recommend selecting these options unless otherwise instructed by your system administrator.
  6. Click OK to save the Local Intranet settings.
  7. If the Security level for this zone is set to Medium-low or Low, no other changes are necessary. Otherwise, continue to Step 2.

Internet Security Settings

Fig. 4,  Microsoft Internet Explorer Local Intranet Security Settings

Using Internet Explorer 6

To change Local intranet zone settings in Internet Explorer:

  1. Open Microsoft Internet Explorer.
  2. From the Tools menu, select Internet Options.
  3. Click on the Security tab.
  4. Select the Local intranet icon and click the Sites... button, as indicated in Fig. 3.
  5. You will see the Local intranet dialog box. Ensure that the Include all network paths (UNCs) check box is selected, as shown in Fig. 3.
  6. Click OK to save the Local Intranet settings.
  7. If the Security level for this zone is set to Medium-low or Low, no other changes are necessary. Otherwise, continue to Step 2.

Internet Security Settings

Fig. 3,  Microsoft Internet Explorer Local Intranet Security Settings

This will change your security settings and may prevent you from seeing the security warning in the future.

Step 2 - Verify Security level for the Local Intranet zone:

  1. From the Security tab of Internet Options (see Step 1), select the Local intranet icon. The Security level for this zone displays what level is currently set. If Medium-low or Low is selected, no other changes are required. However, if High, Medium-High, Medium or Custom is displayed, you may need to change the security level to a lower setting. Setting the zone to the default level, Medium-low, will prevent the Open File - Security Warning from being displayed. However, it is also possible to maintain a higher security setting and still bypass this warning, by changing one of the options in Security Settings. To do this, perform the following steps:
    1. Click Custom level.
    2. Locate the Launching applications and unsafe files option.
    3. Select Enable, as indicated in Fig. 5.
    4. Click OK to save the Local Intranet settings.
  2. Click OK to save the Internet Options settings.

    Note that the Security settings for this zone will now show Custom.

Internet Security Settings

Fig. 6,  Microsoft Internet Explorer Local Intranet Custom Security Settings

Frequently Asked Questions

The Open File - Security Warning message has started to appear again after we've followed the steps to avoid these warnings. Why are we receiving this message again?
This generally is caused by updating from Internet Explorer 7 to Internet Explorer 8, either by the Windows update program or by manually installing Internet Explorer 8. When these updates are installed, the Security settings are reset back to their default values. This means that after each update to Internet Explorer, the procedure to change the Security settings will need to be performed again if the Open File-Security Warning message has reappeared.

References


© 1999-2010 Software Technology, Inc.   All rights reserved. Terms of Use
The maker of Tabs3 and PracticeMaster
Tabs3, PracticeMaster, and the “pinwheel” symbol (The "Pinwheel" symbol is a Registered Trademark of Software Technology, Inc.) are registered trademarks of Software Technology, Inc.
e-Mail Suggestions for the Knowledge Base to: kb@Tabs3.com
Technical Support via e-mail is not available.
Knowledge Base:   http://support.Tabs3.com
Web Site:   http://www.Tabs3.com